Open Test Framework - Solution Explorer (Solution Manager)

From emotive
Jump to: navigation, search


Overview

The Solution Explorer presents the whole OTX solution in a clear tree structure. All the elements are displayed as nodes in the tree-view starting from the "root node" to the ActionRealisations hierarchically. With the display of tree structure and with various commands to modify and handle elements, the Solution Explorer does help users to manage all parts and elements of a solution easily at design-time. It also supports with commands to execute a sequence (a procedure) directly, or to check for errors before execution, or even to build DLLs or executable files etc.

The Solution Explorer is a tool window, so it can be docked, floating, opened, closed, resized or set to auto hide. When starting the OTF the first time, the Solution Explorer is already opened and docked on the right of the Workflow Designer. You can open or close it via the "Solution Explore" button ("SolutionExplorer.png") in the Ribbon. Besides, it has a menu bar with some commands to help users customize the presentation of the solution tree-view. Below are the short descriptions and guidelines for this menu bar:

Menu entry Description
Tooltip switch Turns the tooltips in Solution Explorer ON/OFF.
Display main elements Displays the main elements only (Projects, Pachages, Documents and Procedures).
Display Flow element Turns the display of the flow element of a procedure ON/OFF.
Display only global library elements Hides all the elements in all referenced Ptx libraries that do not have the Visibility:Public (default:ON).
Expand AllExclamation.png Displays all-level elements in the solution.
Collapse All Hides all elements in all projects, only displays the solution node and project nodes.
Up Moves the element up one level within a scope (e.g. moves a variable up one level in the local Declarations scope).
Down Moves the element down one level within a scope.
Sort Items A-Z Arranges elements within a scope in ascending order.
Sort Items Z-A Arranges elements within a scope in descending order.


All the elements of an OTX solution are listed in the following sections with the description of the important aspects, features and commands.

px
The Solution Explorer shows the structure of an OTX solution

SolutionNode.png Solution (root node)

An OTX solution is a standard folder in the file system and it is displayed as the "root node" in the Solution Explorer. The OTX solution folder contains a solution file (*.otfSln) with solution management information (see Solution Settings), and another file (*.otfSuo) to record debug breakpoints, watched variable and information of auto reloading procedures. An OTX solution can have one or many OTX projects but it is not mandatory to have projects in the solution. These OTX projects are displayed as project nodes below the root node and only the project nodes are allowed here. The OTX projects may be located inside or outside the solution folder, the solution references to these projects with relative paths or absolute paths.

To load or to create a solution, you can use the related functions in the Start Page or the "New Solution" command in the menu File of the Ribbon. The name of a solution can be arbitrary but it must comply with the restrictions of the operating system.

Right-click on the solution node, there will be a context menu with the following entries:

Menu entry Description
Overview Opens the Overview window to display the whole designer content of the current solution.
Validate Checks all the documents within the solution for any warnings or errors.
Build Solution Builds the DLL/JAR files of all the projects in the solution.
Rebuild Solution Cleans the solution and builds the DLL/JAR files of all the projects in the solution.
Clean Solution Deletes all the files in the output folder of the Dotnet and Java runtime of all the projects in the solution.
Change all paths to URI Searches all the paths used in all the documents of the solution and converts them to URI
(limits on some activities that use paths).
Export...> Export As PTX... Exports all the projects in the current solution to the PTX library.
Export...> Export As ZIP archive... Exports the current solution to the ZIP archive.
Add > New Project... Adds a new project to the current solution.
Add > New Player Project... Adds a new player project to the current solution.
Add > Existing Project... Adds an existing project to the current solution.
Add > Import project from PTX library... Adds a new project from a PTX library to the current solution.
Add > Import project from PPX library... Adds a new player project from a PPX library to the current solution.
Add > New Project / Player from an existing template Adds a new project/player project to the current solution from an existing template.
Rename Renames the current solution.
Add Solution to Subversion Add the current solution to Subversion.
Version Control (Subversion) > Help... Opens the user manual of the TortoiseSVN.
Version Control (Subversion) > Setting... Opens the "Settings - TortoiseSVN" dialog box.
Version Control (Subversion) > About... Opens the version information dialog box.
Open Folder in Windows Explorer Opens the solution folder in a new window with Windows Explorer.
Properties Opens the Solution Settings dialog box.

Project32.png Projects

Similar to the OTX solution, an OTX project is a standard folder in the file system. It contains a project file (*.otfPrj) with project management information, and the necessary configuration files, also the resources for the OTX extensions etc. (see Project Settings for more information). An OTX project can have one or many OTX packages but it is not mandatory to have packages in the project. The OTX packages are displayed as package nodes below the project node and only the packages nodes are allowed here.

Exclamation.png Important: The names of all the elements below a project node shall conform the OTX Naming conventions!

You can add a new project or add an existing project by using the context menu of the solution. Besides adding a project by the context menu of the solution, you can use the related functions in the Start Page or the "New Project" command in the menu File of the Ribbon. Note that every new project added, a new package and a new document with the "main" procedure will be automatically created in the new project. The name of the new package will be derived from the name of the new project. The name of an OTX project should only contain letters, numbers, underscores and dashes, and the total length of the path to the project should be less than 128 characters (e.g. D:\Solution1\Project1\Project1.otfPrj < 128 characters).

Right-click on the project node, there will be a context menu with the following entries:

Menu entry Description
Overview Opens the Overview window to display the whole designer content of the solution and focuses on the selected project.
Validate Checks all the documents within the project for any warnings or errors.
Display Instructions Displays a page with the notes.
Build Project Builds the DLL/JAR file of the project.
Build Lua ProjectExclamation.png Builds project in Lua code.
Rebuild Project Cleans the project and builds the DLL/JAR files of the projects.
Clean Project Deletes all the files in the output folder of the Dotnet and Java runtime of the projects.
Export...> Export As PTX... Exports the project to a PTX library.
Export...> Export As Template... Exports the project to a PTXT library.
Add > New Package... Adds a new package to the project.
Add > Existing Package... Adds an existing package to the project.
Add > Add PTX library reference... Adds a reference to a PTX library.
Add > [ProjectName]Exclamation.png Adds a reference to the project [ProjectName].
Paste Pastes a package to the project.
Delete Deletes the reference from the solution to the project.
Rename Renames the project.
Set as Startup Project Sets the project as the startup project of the solution.
Add Selected Project to Subversion Adds the selected project to Subversion.
Version Control (Subversion) > Add...Exclamation.png Adds the current project to source control of SVN which needs to be committed to SVN later..
Version Control (Subversion) > Add to ignore list...Exclamation.png Adds the current project to the ignore list so that it will not be added back into Subversion again by mistake.
Version Control (Subversion) > Help... Opens the user manual of the TortoiseSVN.
Version Control (Subversion) > Setting... Opens the "Settings - TortoiseSVN" dialog box.
Version Control (Subversion) > About... Opens the version information dialog box.
Open Folder in Windows Explorer Opens the project folder in a new window with Windows Explorer.
Properties Opens the Project Settings dialog box.
Icons Note.png In the Solution Explorer, you can use keyboard shortcuts with almost all element nodes in the project node (Ctrl+C:Copy, Ctrl+X:Cut, Ctrl+V:Paste). This will be mentioned in some of the following sections where keyboard shortcuts are allowed.

PtxReference32.png References

When a project references to one or many Ptx libraries/projects with relative path or absolute path, these Ptx libraries/projects will be displayed as Ptx nodes below the "References" node of the project. You can add a reference from a project to a Ptx library/projects by using the context menu of the project. To manage the references to the Ptx libraries/projects such as adding, deleting, including Ptx library into project folder or converting references path, you can open "Library Manager" in the "Libraries (PDX References)" tab of the Project Settings, or using the "Library View" command ("LibraryViewAddLib16.png") on the "Test Step Libraries" tab in the Toolbox.

Right-click on the "References" node, there will be a context menu with the following entries:

Menu entry Description
Add > Add PTX library reference... Adds a reference from the project to a PTX library.
Add > [ProjectName]Exclamation.png Adds a reference to the project [ProjectName].
Manage references... Open the "References" in the "References" tab of the Project Settings.

Right-click on the PTX/Project node in the reference node, there will be a context menu with the following entries:

Menu entry Description
Delete Deletes the reference from the project to the PTX library/Project.
Open Folder in Windows ExplorerExclamation.png Opens the folder containing the PTX in a new window with Windows Explorer.

Package32.png Packages

For the structural storage of OTX documents in the file system, the OTX packages are used. A package is simply a folder in the file system whose name corresponds to the OTX Naming conventions. The packages are displayed as package nodes below the project node. Each package can contain other packages (at any depth) or documents, it can also be empty. You can add a new package or an existing package, or paste a package either to a project by using the context menu of the project, or to a package by using the context menu of that package (see below). You can also use the context menu of a package to copy, cut or modify it. Keyboard shortcutsTooltip.png are allowed.

Right-click on the package node, there will be a context menu with the following entries:

Menu entry Description
Overview Opens the Overview window to display the whole designer content of the solution and focuses on the selected package.
Validate Checks all the documents within the package for any warnings or errors.
Add > New Document... Adds a new document to the package.
Add > Existing Document... Adds an existing document to the package.
Add > New Document from an existing template Adds a new document to the current package from an existing template.
Add > Unallocated Document... Adds a document from the "Unallocated Files" section to the package.
Add > All unallocated Documents... Adds all documents from the "Unallocated Files" section to the package.
Add > New Package... Adds a new package inside the current package.
Add > Existing Package... Adds an existing package inside the current package.
Cut Cuts the package.
Copy Copies the package.
Copy complete name Copies the complete OTX name of the package.
Paste Pastes a package or a document to the package.
Delete Deletes the package.
Rename Renames the package.
Open Folder in Windows Explorer Opens the package folder in a new window with Windows Explorer.

Document32.png Documents

An OTX document is an XML file that describes all the data required for a sequence. An OTX document can reference to other OTX documents; see Imports section for detail. All the documents in a package will be displayed as document nodes below the package node. The content of documents are not automatically loaded when loading the solution (except that if a procedure in a document is automatically loaded). To load the content of a document, double-click on the document or use the "Open/View" menu entry in the context menu of the document (see below). You can add a new document or an existing document, or paste a copied or cut document to a package by using the context menu of the package. To copy, cut or modify a document, you can use the context menu of that document. Keyboard shortcutsTooltip.png are allowed.

Right-click on the document node, there will be a context menu with the following entries:

Menu entry Description
Overview Opens the Overview window to display the whole designer content of the solution and focuses on the selected document.
Open/View Loads and expands the content of the document.
View Code (OTL) Opens the OTL editor window of the document.
Validate Checks for any warnings or errors in the document.
Display Instructions Displays a page with the notes.
Meta-Data Opens the Meta Data View tool window.
Save Saves all the changes in the document.
Export...> Export as Single Document... Exports the document to a OTX file.
Add > Import/Reference... Adds a reference from the current document to itself or to another document.
Add > Global Declaration > New Global Constant... Adds a new global constant to the document.
Add > Global Declaration > New Global Variable... Adds a new global variable (document variable) to the document.
Add > Global Declaration > New Context Variable... Adds a new context variable to the document.
Add > Global Declaration > New State Variable... Adds a new state variable to the document.
Add > AdminData Adds administration data (versioning data) to the document (see AdminData).
Add > Validity... Adds a new validity to the document.
Add > Signatures > New Procedure Signature... Adds a new procedure signature to the document.
Add > Signatures > New Screen Signature... Adds a new screen signature to the document.
Add > Signatures > New Device Signature... Adds a new device signature to the document.
Add > Signatures > New Device Signature... Adds a new device signature to the document.
Add > Signatures > New Structure Signature... Adds a new structure signature to the document.
Add > Signatures > New Enumeration Signature... Adds a new enumeration signature to the document.
Add > Signatures > New SingleEcuJob Signature... Adds a new procedure signature with some supported parameters to the document.
Add > Signatures > New FlashJob Signature... Adds a new procedure signature with some supported parameters to the document.
Add > Signatures > New SecurityAccessJob Signature... Adds a new procedure signature with some supported parameters to the document.
Cut Cuts the document.
Copy Copies the document.
Copy complete name Copies the complete OTX name of the document.
Paste Pastes a global element (a validity, a global declataion, or a signature) to the document.
Delete Deletes the document.
Rename Renames the document.
Set as Startup Document Sets the document as the Startup Document of the project.
Open Folder in Windows Explorer Opens the package folder containing the document in a new window with Windows Explorer.
Properties Opens the properties dialog box of the document.

AdminData.png Admin Data

Some OTX documents have a very long lifetime. They may be used or modified by many people, or even they may be exchanged between the process partners. Therefore, the documents should store the information about the change history, the person who responsible for the changes etc. This kind of data is called "Admin-Data". This data can be stored within the document or in a seperate file (*.adminData). The storage method may be set by the "File\Option" menu in the Ribbon. The "Admin-Data" is displayed as the admin-data node below the document node. You can use the context menu of a document to add the "Admin-Data" to that document. To modify the "Admin-Data" of the document, use the context menu of the admin-data node.

Right-click on the admin-data node, there will be a context menu with the following entries:

Menu entry Description
Delete Deletes the "Admin-Data".
PropertiesTooltip.png Opens the admin-data editor dialog box.

Imports32.png Imports

With the import element of a document, references can be made ​​to other documents. The references are displayed as import elements (or import nodes) below the "Imports" node of the document. When a document refers to another document, it imports the global names defined in the referred document (imported document) and it can use these imported global names. However, not all the global names in the imported document are accessible because their Visibility attributes may not be sufficient to the document which imports the other one.

You can add a reference to a document by using the menu context of the current document or the context menu of the "Imports" node of the current document (see below). When you click on the corresponding menu entry, the "Add new reference (Import)" dialog box will appear. Here you can enter the prefix for the reference, note that the prefix must conform to the OTX Naming conventions. The format of an imported global name is "Prefix:ElementName". Through the import prefix, a global name of the imported document can be accessed and can be distinguished from the global names of the other imported documents (e.g. Variable1 = ImportPrefix1:GlobalConstant1 + ImportPrefix2:GlobalConstant1). Besides entering the prefix, you have to select the document you want to add reference to. You can select the document in the list of the available documents displayed in the dialog box, which are all the documents in the current project, in the referenced projects and in the referenced Ptx libraries. Below each project or each Ptx library in the list of available documents, the documents will be displayed by the containing package names and the document names (e.g. "Package1.Package12.Package121:NewDocument1"). Note that you can use a document to import itself. After you have entered a prefix and selected a document to import, click "OK" button to finish the process and then you can access all the global names with sufficient Visibility in the current document. To modify a reference, use the context menu of the import node of the reference (see below).

Right-click on the "Imports" node, there will be a context menu with the following entries:

Menu entry Description
Add Item Adds a reference from the current document to itself or to another document.

Right-click on an import node, there will be a context menu with the following entries:

Menu entry Description
Delete Deletes the reference.
PropertiesTooltip.png Opens a dialog box to modidfy the reference.

Validity32.png Validities

Validities allow for configuring test sequences for different runtime contexts. A Validity is any logical expression which usually consists of contextual variables or global constants. All the validities in a document are displayed as validity nodes below the "Validities" node. To add or to paste a validity to a document, you can use the context menu of the document or the context menu of the Validities node (see below). You can also copy, cut or modify a validity by using the context menu of that validity. Keyboard shortcutsTooltip.png are allowed.

Right-click on the "Validities" node, there will be a context menu with the following entries:

Menu entry Description
Add Item Adds a new validity to the document.
Paste Pastes a validity to the document.

Right-click on a validity node, there will be a context menu with the following entries:

Menu entry Description
Cut Cuts the validity.
Copy Copies the validity.
Copy complete name Copies the complete OTX name of the validity.
Delete Deletes the validity.
Rename Renames the validity.
PropertiesTooltip.png Opens the properties dialog box of the validity.

Signature32.png Signatures

A signature describes the interface for a procedure, a screen or an external diagnostic application. All the signatures in a document are displayed as signature nodes below the "Signatures" node. To add or to paste a signature, you can use the context menu of the document or the context menu of the "Signatures" node (see below). To copy, cut or modify a signature, use the context menu of that signature. Keyboard shortcutsTooltip.png are allowed.

Right-click on the "Signatures" node, there will be a context menu with the following entries:

Menu entry Description
Add Item > New Procedure Signature... Adds a new procedure signature to the document.
Add Item > New Screen Signature... Adds a new screen signature to the document.
Add Item > New Device Signature... Adds a new device signature to the document.
Add Item > New Structure Signature... Adds a new structure signature to the document.
Add Item > New Enumeration Signature... Adds a new enumeration signature to the document.
Add Item > New SingleEcuJob Signature... Adds a new procedure signature with some supported parameters to the document.
Add Item > New FlashJob Signature... Adds a new procedure signature with some supported parameters to the document.
Add Item > New SecurityAccessJob Signature... Adds a new procedure signature with some supported parameters to the document.
Paste Pastes a signature to the document.

Right-click on a signature node, there will be a context menu with the following entries:

Menu entry Description
Implement new ProcedureExclamation.png Creates a new procedure and uses the procedure to implement the current procedure signature.
Cut Cuts the signature.
Copy Copies the signature.
Copy complete name Copies the complete OTX name of the document.
Delete Deletes the signature.
Rename Renames the signature.
Add new realisationExclamation.png Adds a new realisation to the signature.
Delete realisationExclamation.png Deletes the realisation of the signature.
PropertiesTooltip.png Opens the properties dialog box of the signature.

AddVariable32.png Global Declarations

Global declarations contains all the global constants and variables (context variables, state variables and document variables) which are visible in the whole document. These global constants and variables can also be imported and used in external documents according to their Visibility attribute. All the global declarations in a document are displayed as global declaration nodes below the "Declarations" node of the document (note that a procedure also has a "Declarations" node). To add or to paste a global declaration, you can use the context menu of the document or the context menu of the "Declarations" node of the document (see below). Note the special case that you can paste a global constant or a document variable to the local "Declarations" node (the copy of a global constant will be a local constant, and the copy of a document variable will be a local variable, context variables and state variables are not allowed). To copy, cut or modify a global declaration, use the context menu of that global declaration. Keyboard shortcutsTooltip.png are allowed.

Right-click on the "Declarations" node of the document, there will be a context menu with the following entries:

Menu entry Description
Add > New Global Constant... Adds a new global constant to the document.
Add > New Context Variable... Adds a new context variable to the document.
Add > New Global Variable... Adds a new global variable (document variable) to the document.
Add > New State Variable... Adds a new state variable to the document.
Paste Pastes a global declaration to the document.
Delete not used declarations Deletes all the unused global declarations.

Right-click on a global declaration node, there will be a context menu with the following entries:

Menu entry Description
Add to Watch window Adds the global declaration to the Watch tool window.
Cut Cuts the global declaration.
Copy Copies the global declaration.
Copy complete name Copies the complete OTX name of the global declaration.
Delete Deletes the global declaration.
Rename Renames the global declaration.
PropertiesTooltip.png Opens the properties dialog box of the global declaration.

Procedure32.png Procedures

A procedure is an executable part of an OTX document. It describes the actual sequences. A procedure (usually the procedure with the name "main") can be used as the entry point of a test sequence to be executed, or it can be called by a ProcedureCall activity from another OTX procedure. All the procedures in a document are displayed as procedure nodes below the "Procedures" node of the document. To add a new procedure or paste a procedure, you can use the context menu of the "Procedures" node (see below). To copy, cut or modify a procedure, use the context menu of the procedure node. Keyboard shortcutsTooltip.png are allowed.

Right-click on the "Procedures" node, there will be a context menu with the following entries:

Menu entry Description
Add Item... > New Procedure... Adds a new procedure to the document.
Add Item... > New Procedure from an existing template Adds a new procedure to the document from an existing template.
Paste Pastes a procedure to the document.

Right-click on a procedure node, there will be a context menu with the following entries:

Menu entry Description
Overview Opens the Overview window to display the whole designer content of the solution and focuses on the selected procedure.
Open/View Opens the procedure in the Workflow Designer.
View Code (OTL) Opens the OTL editor window of the document and focuses on the selected procedure.
Validate Checks the procedure for any errors and warnings.
Display Instructions Displays a page with the notes.
Meta-Data Opens the Meta Data View tool window.
Execute Workflow Executes the procedure.
Stop ProcedureExclamation.png Stop the execution of the procedure.
Update ParametersExclamation.png Updates the parameters and the exception declarations (see Throws) according to the implemented procedure signature.
Create ProcedureSignature from Procedure Creates a new procedure signature in the current document and uses the current procedure to implement the procedure signature (the parameters and exceptions of the signature are based on the current procedure).
Cut Cuts the procedure.
Copy Copies the procedure.
Copy complete name Copies the complete OTX name of the procedure.
Paste Pastes a local element (a comment, a parameter, an exception or a declaration) to the procedure.
Delete Deletes the procedure.
Rename Renames the procedure.
Add > Comment... Adds a comment to the procedure.
Add > Parameter > New Procedure In-Parameter... Adds an in parameter to the procedure.
Add > Parameter > New Procedure out-Parameter... Adds an out parameter to the procedure.
Add > Parameter > New Procedure In/Out-Parameter... Adds an in/out parameter to the procedure.
Add > Throw... Adds an exception declaration to the procedure.
Add > Local declaration > New Local Constant... Adds a new local constant to the procedure.
Add > Local declaration > New Local Variable... Adds a new local variable to the procedure.
Add new realizationExclamation.png Adds new realisation to the procedure.
Delete RealizationExclamation.png Delete the realisation of the procedure.
Properties Opens the properties dialog box of the procedure.

Comments32.png Comments

A comment contains a human readable information and a list of links pointing to the activities that are related to the comment. Comments are used for additional descriptions besides specification of activities. All the comments in a procedure are displayed as comment nodes below the "Comments" node of the procedure. To add a new comment or paste a comment, you can use the context menu of the current procedure or the context menu of the "Comments" node (see below). You can also add a new comment directly to an activity in the Workflow Designer by using the context menu of that activity. You can also add a link between an existing comment and an activity by dragging the comment node from the Solution Explorer and dropping it on the activity in the Workflow Designer. To copy, cut or modify a comment, use the context menu of that comment (see below). Keyboard shortcutsTooltip.png are allowed.

Right-click on the "Comments" node, there will be a context menu with the following entries:

Menu entry Description
Add Item... Adds a new comment to the procedure.
Paste Pastes a comment to the procedure.

Right-click on a comment node, there will be a context menu with the following entries:

Menu entry Description
Cut Cuts the comment.
Copy Copies the comment.
Delete Deletes the comment.
PropertiesTooltip.png Opens the editor dialog box of the comment.

Parameters32.png Parameters

The parameter declaration block may contain In-, Out- or InOut- parameters of procedures or signatures (Note that the "Term-Parameter" declaration is only for screen signature). The parameters will be displayed as parameter nodes below the "Parameters" node (this is the parameter declaration block). To add or to paste a parameter, use the context menu of the "Parameters" node of the procedure or the signature (see below), you can also use the context menu of the procedure. To copy, cut or modify a parameter, use the context menu of that parameter (see below). Note that you can paste a copied or cut parameter from a procedure signature to a procedure and vice versa, but no other signature types are allowed. Besides, it is only allowed to paste a parameter from a signature to another signature with the same realisation (e.g. screen signature to screen signature). Keyboard shortcutsTooltip.png are allowed in legal cases.

Right-click on the "Parameters" node, there will be a context menu with the following entries:

Menu entry Description
Update ParametersExclamation.png Updates the parameters and the exception declarations (see Throws) of the procedure according to the implemented procedure signature.
Add > New Procedure In-Parameter... Adds an in parameter to the procedure.
Add > New Procedure out-Parameter... Adds an out parameter to the procedure.
Add > New Procedure In/Out-Parameter... Adds an in/out parameter to the procedure.
Paste Pastes a parameter to the procedure or signature.

Right-click on a parameter node, there will be a context menu with the following entries:

Menu entry Description
Add to Watch window Adds the parameter to the Watch tool window.
Cut Cuts the parameter.
Copy Copies the parameter.
Copy complete name Copies the complete OTX name of the parameter.
Delete Deletes the parameter.
Rename Renames the parameter.
PropertiesTooltip.png Opens the properties dialog box of the parameter.

Throws32.png Throws (exceptions)

The author of the OTX document can predict the exceptions that may potentially be thrown during execution. These exceptions shall be declared in the "Throws" (exceptions) nodes of the procedure signatures, the device service signatures and the procedures. The exception declarations can inform other persons who re-use the sequence the potential exceptions in order to handle them. Note that (1) the implemented procedure signature of the current procedure, or (2) the procedure calling to the current procedure (or to the implemented procedure signature) should also declare the same exceptions in their "Throws" nodes. Each declared exception is displayed as an exception node in the "Throws" node. To add or to paste an exception, use the context menu of the procedure or the context menu of the "Throws" node (of the procedure, the procedure signature or the device service signature, see below). To copy or cut an exception, use the context menu of that exception. Keyboard shortcuts{{Toolti]]pIcon|(Ctrl+C:Copy, Ctrl+X:Cut, Ctrl+V:Paste)}} are allowed.

Right-click on the "Throws" node, there will be a context menu with the following entries:

Menu entry Description
Add Item... Adds a new exception to the "Throws" node.
Paste Pastes an exception to the "Throws" node.

Right-click on a exception node, there will be a context menu with the following entries:

Menu entry Description
Cut Cuts the exception.
Copy Copies the exception.
Delete Deletes the exception.

LocalDeclarations32.png Local Declarations

Local declaration block is used to declare all the local constants and local variables which are only valid in their respective procedure. These constants and variables can not be accessed or used outside of the procedure. These local declarations are displayed as local declaration node below the local "Declarations" node of the procedure (this node is different from the global "Declarations" node of the document). To add or to paste a local declaration, use the context menu of the procedure or the context menu of the local "Declarations" node (see below). To copy, cut or modify a local declaration, use the context menu of that local declaration (see below). Note the special case in which you can paste a local constant or a local variable to the global "Declarations" node (the copy of a local constant will be a global constant, and the copy of a local variable will be a document variable). Keyboard shortcutsTooltip.png are allowed.

Right-click on the local "Declarations" node of the procedure, there will be a context menu with the following entries:

Menu entry Description
Add > New Local Variable... Adds a new local variable to the procedure.
Add > New Local Constant... Adds a new local constant to the procedure.
Paste Pastes a local declaration to the procedure.
Delete not used declarations... Deletes all the unused local declarations.

Right-click on a local declaration node, there will be a context menu with the following entries:

Menu entry Description
Add to Watch window Adds the local declaration to the Watch tool window.
Cut Cuts the local declaration.
Copy Copies the local declaration.
Copy complete name Copies the complete OTX name of the local declaration.
Delete Deletes the local declaration.
Rename Renames the local declaration.
PropertiesTooltip.png Opens the properties dialog box of the local declaration.

Flow32.png Flow

Under the flow node, the actual sequence of activities is presented. Each activity consists of a name and one or more realisations. An activity is displayed as activity node below the flow node, inside an activity node there may be a realisation node or another activity node (the case of compound nodes). The flow node has no context menu but the activity node or the realisation node has a context menu with some limited functions. To edit the activity, please use the Workflow Designer.

Right-click on an activity node or a realisation node, there will be a context menu with the following entries:

Menu entry Description
Open/ViewExclamation.png Opens (or sets on top) the procedure tab of the activity.
Delete Deletes the activity (or the deletable flow of a compound node).
Add new realizationExclamation.png Adds new realisation to the "Catch" flow of the handler activity.
Delete RealizationExclamation.png Deletes the realisation of the "Catch" flow of the handler activity.
Add Catch-branchExclamation.png Adds a new "Catch" flow to the handler activity.
Add Finally-branchExclamation.png Adds a new "Finally" flow to the handler activity.
Properties Opens the properties dialog box of the element which has the adjustable properties.

ProjectPlayer32.png Player Projects

Similar to the OTX projects, a Player project is a standard folder in the file system. It contains a Project file (*.playPrj), a PlayList file (*.playLst) and a PlayerLayout file (*.playLay)

Exclamation.png Important: The names of all the elements below a player project node shall conform the OTX Naming conventions!

You can add a new player project or import from a PPX library by using the context menu of the solution. Besides adding a player project by the context menu of the solution, you can use the related functions in the Start Page or the "New Player Project" command in the menu File of the Ribbon.

Right-click on the player project node, there will be a context menu with the following entries:

Menu entry Description
Overview Opens the Overview window to display the whole designer content of the solution and focuses on the selected player project.
Validate Checks all the referred PTX/project within the player project for any warnings or errors.
Display Instructions Displays a page with the notes.
Export...> Export As PPX... Exports the player project to a PPX library.
Export...> Export As Template... Exports the player project to a PTXT library.
Add > Add PTX library reference... Adds a reference to a PTX library.
Add > Import Player Layout... Imports a file layout (*.playLay) from another player project.
Add > [ProjectName]Exclamation.png Adds a reference to the project [ProjectName].
Delete Deletes the reference from the solution to the player project.
Rename Renames the player project.
Add Selected Project to Subversion Adds the selected player project to Subversion.
Version Control (Subversion) > Add...Exclamation.png Adds the current player project to source control of SVN which needs to be committed to SVN later..
Version Control (Subversion) > Add to ignore list...Exclamation.png Adds the current player project to the ignore list so that it will not be added back into Subversion again by mistake.
Version Control (Subversion) > Help... Opens the user manual of the TortoiseSVN.
Version Control (Subversion) > Setting... Opens the "Settings - TortoiseSVN" dialog box.
Version Control (Subversion) > About... Opens the version information dialog box.
Open Folder in Windows Explorer Opens the player project folder in a new window with Windows Explorer.
Properties Opens the Project Settings dialog box.

PtxReference32.png References

Similar to the References of the OTX projects

Monitors.png Monitors

The monitor consits of an adjustable table layout with different panels which contain the controls or commands. The "Monitors" are displayed as monitors node below the player project node. Each "Monitors" can contain one or more the monitor and it can also be empty. To add or to paste a monitor, you can use the context menu of the "Monitors" node (see below) or you can add the existing monitors of other player project by using the context menu of the player project (Add > Import Player Layout...). To copy or cut a monitor, use the context menu of that monitor. Keyboard shortcutsTooltip.png are allowed.

Right-click on the "Monitors" node, there will be a context menu with the following entries:

Menu entry Description
Add > New Monitor... Adds a new monitor to the "Monitors" node.
Paste Pastes a monitor to the "Monitors" node.
Open Folder in Windows Explorer Opens the player project folder in a new window with Windows Explorer.

Right-click on a monitor node, there will be a context menu with the following entries:

Menu entry Description
Open/View Opens the monitor in the Workflow Designer.
Cut Cuts the monitor.
Copy Copies the monitor.
Delete Deletes the monitor.

Right-click on a "Comlumns/Rows" node, there will be a context menu with the following entries:

Menu entry Description
Properties Opens the properties dialog box of the Column/Row.

Right-click on a panel node (e.g ControlPanels, CommandPanels and HmiScreenPanels), there will be a context menu with the following entries:

Menu entry Description
Add Item... Opens dialog to add new panel to the ControlPanels or CommandPanels or HmiScreenPanels.
Paste Pastes a panel to the ControlPanels or CommandPanels or HmiScreenPanels.

Right-click on a "PanelControl" node (or "PanelCommand" or "PanelHmi"), there will be a context menu with the following entries:

Menu entry Description
Add Item...Exclamation.png Opens dialog to add new element to the panelHmi.
Cut Cuts the panelControl or panelCommand or panelHmi.
Copy Copies the panelControl or panelCommand or panelHmi.
PasteExclamation.png Pastes a control to the panelControl.
Delete Deletes the panelControl or panelCommand or panelHmi.

Right-click on a control node (or Command or Hmi element), there will be a context menu with the following entries:

Menu entry Description
CutExclamation.png Cuts the control.
CopyExclamation.png Copies the control.
Delete Deletes the control or command or Hmi element.

PlayLists.png Playlists

Right-click on the "Playlist" node, there will be a context menu with the following entries:

Menu entry Description
Add > New Playlist Adds a new playlist to the "Playlist" node.
Paste Pastes a playlist to the "Playlist" node.

Right-click on the playlist element node, there will be a context menu with the following entries:

Menu entry Description
Open/View Opens the playlist in the Workflow Designer.
Cut Cuts the playlist element.
Paste Pastes the playlist element.
Delete Deletes the playlist element.

GlobalBehaviors.png Global Behaviours

Right-click on the "Global Behaviours" node, there will be a context menu with the following entries:

Menu entry Description
Add Item... Open the "Behaviour - settings" dialog to add a new global behaviour element.
Paste Pastes a global behaviour element to the "global behaviours" node.

Right-click on the global behaviour element node, there will be a context menu with the following entries:

Menu entry Description
Cut Cuts the global behaviour element.
Copy Copies the global behaviour element.
Delete Deletes the global behaviour element.
Properties Open the "Behaviour - settings" dialog.

InitialValues.png Initial Values

Right-click on the "Initial Values" node, there will be a context menu with the following entries:

Menu entry Description
Open/View Open the "Behaviour - settings" dialog to add a new global behaviour element.
Open Folder in Windows Explorer Opens the player project folder in a new window with Windows Explorer.

UnallocatedFiles16.png Unallocated Files

The OTF allows you to load an OTX document directly in the Solution Explorer. To load an OTX document, you should set the OTX document format (*.otx) to be opened with the OTF (right-click on a document and select menu "Open With", and set the OTF to open this file format). After that, double-click on any document to load it in the explorer. If a solution is already loaded in the explorer and the document belongs to the current solution, the document will be focused and opened; otherwise, the document will be loaded as an unallocated document in the explorer. An unallocated document will be displayed as an allocated document node below the "Unallocated Files" node. All unallocated documents is read-only but you can copy the unallocated document or all the elements inside the unallocated document by using the context menu of the corresponding element node, you can also open the properties dialog box of those element by using the context menu. To edit an unallocated document, you can add that document to a package in the solution. To add one or all of the allocated document to a package, please use the context menu of the corresponding package node. When you reload the solution or load another solution, the "Unallocated Files" will be cleared.